Centroid Error

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Centroid Error

Maxim Usatov
Hi All,

For some reason AIJ started to tell me this when I am doing differential photometry and trying to place apertures:
***ERROR: No signal for centroid in aperture T1 of image Calibrated-T18-blackhaz-WTF Star-20160828-020624-Ha-BIN1-W-300-001.fit.
********: Measurements are referenced to the non-centroided aperture location

There's star in the aperture. Exactly on the same image, yesterday, I was able to do this without problems. Nothing changed in the image. Tested on different images, I get the same error everywhere.

Any ideas?

Max
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Centroid Error

karenacollins
Administrator

Hi Max,

Are the images properly calibrated? In other words, does the background happen to have negative values? If so, the centroid will not work. In that case, re-calibrate the images with appropriate bias, and/or darks, and/or flats. If this is not the problem, please post an example of a screen shot showing the aperture T1 placement on the star. Also post the Sky/Pixel_T1 value from the measurements table for that image and aperture number.

Karen


On 9/10/2016 2:50 AM, Maxim Usatov [via AstroImageJ] wrote:
Hi All,

For some reason AIJ started to tell me this when I am doing differential photometry and trying to place apertures:
***ERROR: No signal for centroid in aperture T1 of image Calibrated-T18-blackhaz-WTF Star-20160828-020624-Ha-BIN1-W-300-001.fit.
********: Measurements are referenced to the non-centroided aperture location

There's star in the aperture. Exactly on the same image, yesterday, I was able to do this without problems. Nothing changed in the image. Tested on different images, I get the same error everywhere.

Any ideas?

Max


If you reply to this email, your message will be added to the discussion below:
http://astroimagej.1065399.n5.nabble.com/Centroid-Error-tp503.html
To start a new topic under How to accomplish specific tasks in AstroImageJ, email [hidden email]
To unsubscribe from AstroImageJ, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Centroid Error

karenacollins
Administrator
In reply to this post by Maxim Usatov
Hi Max,

Are the images properly calibrated? In other words, does the background
happen to have negative values? If so, the centroid will not work. In
that case, re-calibrate the images with appropriate bias, and/or darks,
and/or flats. If this is not the problem, please post an example of a
screen shot showing the aperture T1 placement on the star. Also post the
Sky/Pixel_T1 value from the measurements table for that image and
aperture number.

Karen

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Centroid Error

Maxim Usatov
Hi Karen,

Yes, they are properly calibrated. AIJ worked fine on this data yesterday. I was able to resolve the problem by removing by ~/Library/Preferences/AIJ_Prefs.txt and it began working beautifully again. I am not sure what happened. If you still need me to post my data, let me know.

Max
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Centroid Error

karenacollins
Administrator
Okay, great. If it happens again, let me know and we will work out a way
for you to send the AIJ_Prefs.txt file to me so I can find what setting
is causing the problem.

Karen

Loading...